Bought 81 v6 231 A Camaro need help

Discussion in 'Troubleshooting & Diagnosis' started by SetosCamaro, Apr 16, 2012.

  1. SetosCamaro

    SetosCamaro New Member

    15
    0
    Apr 16, 2012
    Happy Valley, OR

    Thanks! yea.. now that you mention it there is a plug just hanging loose in the engine area on the right side of the engine... I haven't figured out where it goes yet ...its been that way since I got it.. hmm well I guess I'll have to figure out that mystery. It feels like the problem is fuel related, getting too much air and not enough gas at times. I will go through your suggestions as well when I get a change, still need to get a timing light and Tachometer (though with the cost of it I might as well get one and put one in the dashboard or something). It's amazing how most people have the V8 engine and get rid of the V6, there must be a big difference in performance.
    This weekend I think I'm going to change the fuel filter, fix some of the car's rust parts in the trunk and try to find something to seal the windows a little more (they are leaking) untill I can get them re-done re-sealed again with the proper weather seals, fix my dashboard (previous owner I think painted the dashboard and never put the screws back in so it vibrates badly, put grease on the speedometer (its making a really loud rubbing noise)
     
  2. SetosCamaro

    SetosCamaro New Member

    15
    0
    Apr 16, 2012
    Happy Valley, OR
    Quick update from this weekend. Got Timing Light.. car seems to be correct at 15 degrees . Rpms were a little high 1000 on idle(after the car was warmed up) No real way to adjust it but did Discover EGR hose was completely plugged by previous owner with a screw and was not connected to EGR at all. Changed Fuel Filter (it was dirty as hell). Rpms dropped to about 800 rpms. Car seems to have re-gained some of its power (so far) will have to try it for work tommorrow and see how it goes.


    Update: Car is running a little better but still struggles with high speed 50-60 mph also if car isn't all the way warm (in the morning) the car will die when idling in drive, when its warm its fine.
     
    Last edited: Apr 23, 2012
  3. SetosCamaro

    SetosCamaro New Member

    15
    0
    Apr 16, 2012
    Happy Valley, OR
    yea its still having problems. I tried soap and water/ Carb cleaner to try to find a vacuum leak .. couldn't find any. Going to try to replace the fuel pump next. Hope that does .. its sounding more and more like I might have to deal with the carburetor if that doesn't work.
     

Share This Page