engine offset

Discussion in 'Engine Topic' started by mrsbojigger, Aug 17, 2005.

  1. mrsbojigger

    mrsbojigger New Member

    16
    0
    Aug 5, 2005
    san antonio, tex. usa
    Installing LS1 engine into '80 Camaro. I have measured from side to side with engine in place. The engine sets 1" to the right (passenger side). Is this correct? Is this to factory specs? My mechanic doesn't know. I know my Hudson has an offset engine.
    Chaz
     
  2. retorq

    retorq Veteran Member

    4,920
    0
    May 13, 2003
    Kingman, AZ
    Yes, I ran into the same thing when I cut a 16 inch hole in the center my hood for the air cleaner!! I ended up having to cut it to 18 to get it to look right. I was told it was normal and due to the steering linkage.
     
  3. 80'427

    80'427 Veteran Member

    1,886
    0
    Jan 1, 2005
    Fairbury, NE, USA
    I will tell you after changing plugs in my 99 firebird tonight the factory LS1 sits closer to the pass side by at least a inch if not more.
     
  4. mrsbojigger

    mrsbojigger New Member

    16
    0
    Aug 5, 2005
    san antonio, tex. usa
  5. dgwar

    dgwar Veteran Member

    555
    0
    Mar 22, 2005
    Santee,South Carolina
    I had the same problem when I put my Big Block in...turns out I missed the hole on the motor mount. bolt went through the outside mounting holes fine and missed the inside mount hole.
    I jacked that side back up and slid the inside mount back in place installed the bolt and now it sets level.

    ------------------
     

Share This Page