350 sbc runs rough

Discussion in 'Engine Topic' started by Justin Berke, Jan 11, 2019.

  1. Justin Berke

    Justin Berke New Member

    16
    0
    Jan 11, 2019
    British Columbia
    I'm new to the site and I didnt really see anything related to what's happening to me. So today I tried to start my sbc after a month of not starting it, normally it starts up fine, but when I tried starting it, it wouldnt start unless I held the pedal 3/4 throttle and when it did start it ran extremely rough. It would also not idle. It is around 15°C here, and a month ago she would start up in -5°C. I would have to hold the rpms above 1100rpm to keep her from stalling. So I got new spark plugs and still nothin changed. I couldnt hear any vacuum leaks either. I even reset the carb to factory settings. And it would backfire when i kept it at 2000rpm,
    Any ideas?
    Thanks,
     
  2. wnmech

    wnmech Veteran Member

    836
    60
    Jul 20, 2014
    grand prairie tx.
    Could your timing of slipped? Could your float be sticking? Just a couple of things to check.
     
  3. Justin Berke

    Justin Berke New Member

    16
    0
    Jan 11, 2019
    British Columbia
    How do I check/fix if my float is sticking? And I will be checking the timing tomorrow
     
  4. Gary S

    Gary S Administrator Lifetime Gold Member

    21,531
    427
    Apr 14, 1999
    Bismarck, North Dakota
    That sounds like the choke is malfunctioning. If the choke closes too far, it will run rough and put out black smoke. If the choke isn't closing enough, it will be difficult to keep running at low rpms. Do a basic visual inspection of the choke and how it is functioning in the cold weather.
     
    Justin Berke likes this.
  5. Justin Berke

    Justin Berke New Member

    16
    0
    Jan 11, 2019
    British Columbia
    Okay will do
     

Share This Page