fast ez efi problem

Discussion in 'High Tech Retrofits' started by garyandcindy, Nov 30, 2013.

  1. dale68z

    dale68z Veteran Member

    Messages:
    1,338
    Likes Received:
    18
    Joined:
    May 14, 2009
    Location:
    Glendale Arizona

    My buddy is still waiting for his MAP sensor from FAST.
     
  2. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,604
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    When you call tech support and get put on hold listen to an option that says"if for any reason you are not satisfied with tech suppport ask to speak with the technical services manager".Ask to speak to him.I've spoken with him and he has been extremely helpful in getting a little extra attention paid to my problems.I got another ecu late yesterday and i am going to install it tomorrrow.Hopefully this will fix my current problems.
     
  3. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,604
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    Just got thru installing the new ecu.Started right up and so far so good.It's idling and running just like it did before everything screwed up.I'm gonna keep my fingers crossed that it stays this way:)Appears to have been the ecu the whole time.
     
  4. bygblok

    bygblok Veteran Member

    Messages:
    767
    Likes Received:
    5
    Joined:
    Nov 28, 2010
    Location:
    Pensacola Florida
    Geez I hope this fixes it. Gotta get it straight for some good spring weather cruisin'!
     
  5. John Wright

    John Wright Veteran Member Lifetime Gold Member

    Messages:
    14,620
    Likes Received:
    191
    Joined:
    Aug 9, 2002
    Location:
    Rustburg, Va
    Hopefully you'll be able to get out and enjoy this thing now.
     
  6. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,604
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    Drove it about 2 hours this evening.Ran great!Burn't some gas and some rubber!!:)
     
  7. bygblok

    bygblok Veteran Member

    Messages:
    767
    Likes Received:
    5
    Joined:
    Nov 28, 2010
    Location:
    Pensacola Florida
    AWESOME!!
     
  8. Rene Melten

    Rene Melten Veteran Member Lifetime Gold Member

    Messages:
    4,059
    Likes Received:
    7
    Joined:
    Sep 22, 2007
    Location:
    Blind Bay, B.C.
    Been following this with interest, my fingers are crossed too.
    Merry Christmas by the way.:)
     
  9. dale68z

    dale68z Veteran Member

    Messages:
    1,338
    Likes Received:
    18
    Joined:
    May 14, 2009
    Location:
    Glendale Arizona
    After getting a new MAP from FAST about a month ago(because they said it is bad) The car still runs bad.
    Injection system is now off the car. The car is back to a carb and running great. Like it used to.

    Summit is refunding my friend's money.

    I'm sure I could have diagnosed the problem. But he lost faith in the system. He has to be confident it will not have stupid/ hard to fix issues when on the road.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.