Fuel sending unit - How does it function?

Discussion in 'Troubleshooting & Diagnosis' started by mike d, Sep 3, 2004.

  1. mike d

    mike d Veteran Member

    659
    0
    Jun 18, 2001
    Maine
    I put a new fuel pump in with all new fuel line back to the sending unit. I'm pretty sure that the fuel pump and rod was put in correctly. I have taken the tank off twice to see what might be happening with the sending unit because I am still not getting fuel to the carb. I am starting to get frustrated.

    When I took off the last rubber hose fitting that attaches to the sending unit "tube" that is exposed outside of the tank, I noticed that fuel actually came out from the sending unit tube. Therefore, my thought that the tube was clogged doesn't fly.

    However, I still have no idea how the fuel sending unit actually works...because if it's purpose is simply to indicate how much fuel is the tank and nothing else I still have a problem.

    Any ideas??
     
  2. Batman

    Batman Administrator Staff Member Lifetime Gold Member

    8,673
    6
    Dec 13, 1999
    Mission Viejo, CA, USA
    The fuel sending unit for the gauge is a float attached to a potentiometer (variable resistor). Depending on where the float is will determine the resistance, and thus the indication on the gauge. No fuel actually flows through the sender to the carburator.

    Depending on the model year of tank, there may be 2 to 3 tubes coming off the tank; one for the actual fuel, a vent tube, and sometimes a return tube from the fuel pump. Make sure you're hooked into the right tube. Hope this helps.
     
  3. mike d

    mike d Veteran Member

    659
    0
    Jun 18, 2001
    Maine
    Batman - Thanks for the information. It is a 70 and the only tube I can see at all is the one that is hooked diretcly to the fuel line, period...there is nothing else there. So, if fuel was splashing out of the tube does that sound to you like it should be getting fuel at least up to the pump if everything else is unobstructed inside the fuel lines?

    I was kind of thinking that if there were no "active mechanics" in the sending unit that forced fuel to the pump...and most of the unit is there to simply allow the fuel gauge to work...then I MAY have an issue with the fuel pump...Any thoughts?
     
  4. Batman

    Batman Administrator Staff Member Lifetime Gold Member

    8,673
    6
    Dec 13, 1999
    Mission Viejo, CA, USA
    Sounds like a bad fuel pump. Do you have the mechanical pump on the front passenger's side of the engine, or an aftermarket electric pump mounted somewhere else?
     
  5. mike d

    mike d Veteran Member

    659
    0
    Jun 18, 2001
    Maine
    Yup..I do have the mechanical fuel pump on the pasenger side of the engine. Thought I was a genius when I got everything on the engine when it was on the stand and thought I'd "never" have to take anything off...now it looks like I might need to swap out my fuel pump.

    To tell you the truth, I really sweated making sure that I got the rod properly seated before I put the pump on...more challenging when the engine is in the car..
     

Share This Page