Need Help LT1 Cranks but will not start

Discussion in 'High Tech Retrofits' started by 3_z28camaro, Apr 19, 2009.

  1. 3_z28camaro

    3_z28camaro Veteran Member Lifetime Gold Member

    Messages:
    4,447
    Likes Received:
    0
    Joined:
    Dec 17, 2004
    Location:
    Acton, CA
    Well the engine that these injectors were from sat around for a very long time, some where in the range of a few years. The engine came from a wrecked '94 Z28 and I rebuilt the engine because one of the heads was damaged in the accident and water was allowed to seep everywhere into the engine.

    When I opened it up this is what it looked like:
    [​IMG]
     
  2. Dangerous Drew

    Dangerous Drew Veteran Member

    Messages:
    322
    Likes Received:
    0
    Joined:
    Feb 11, 1999
    Location:
    Waco, TX
    Eww, oh man that's nasty.

    I pulled my donor motor this weekend, and one of the things I'm thinking about is how to preserve the injectors. I ran some Stabil through the fuel system before tearing it down, and I'm going to pull the rails, dump all the old fuel out, and shake out the injectors before storing the motor.

    A previous car that I had, it had sat around for a few years without running. It didn't run until I swapped out the injectors. I tested them by hacking an old wiring harness and making an injector "test clip". I plugged the test clip in and hit the injector with 12V. If the injector solenoid "ticked", it was good. If there was no noise at all, the injector was obviously not working and was gummed up. None of the injectors from that motor 'ticked', but all of the replacements did.
     
  3. drptop70ss

    drptop70ss Veteran Member

    Messages:
    700
    Likes Received:
    2
    Joined:
    Jul 19, 1999
    Location:
    NY zip 12538
    if you have injector pulses, spark, and 40psi fuel pressure then all is well, try tapping on the injectors to see if they will free up. I would spray some starter fluid in the TB just to see if it fires off.
     
  4. 3_z28camaro

    3_z28camaro Veteran Member Lifetime Gold Member

    Messages:
    4,447
    Likes Received:
    0
    Joined:
    Dec 17, 2004
    Location:
    Acton, CA
    I have a spare set of new injectors that will be making their way onto the engine this week. Hopefully that will solve the problem.
     
  5. Aceshigh

    Aceshigh Veteran Member Lifetime Gold Member

    Messages:
    26,757
    Likes Received:
    6
    Joined:
    Apr 9, 2001
    Location:
    Boondocks
  6. 3_z28camaro

    3_z28camaro Veteran Member Lifetime Gold Member

    Messages:
    4,447
    Likes Received:
    0
    Joined:
    Dec 17, 2004
    Location:
    Acton, CA
    That looks like an interesting little device there.
     
  7. 3_z28camaro

    3_z28camaro Veteran Member Lifetime Gold Member

    Messages:
    4,447
    Likes Received:
    0
    Joined:
    Dec 17, 2004
    Location:
    Acton, CA
    Great news everyone! The 1971 Camaro lives again!!!

    I fired it up last night, in the end the problem turned out to be a botched wiring harness by Jeff Roberts and clogged fuel injectors. It ran pretty well. I just let it idle for a little bit, did not bring the RPM up. There are still some electrical demons to vanquish but most importantly it now runs.

    A big thanks to everyone here that helped and also Speartech who I will be using in the future for my 1969 Camaro LS1 swap.
     
    Last edited: Jul 18, 2009
  8. maxpsi

    maxpsi Veteran Member

    Messages:
    610
    Likes Received:
    1
    Joined:
    Jul 10, 2007
    Location:
    Alabama
  9. 3_z28camaro

    3_z28camaro Veteran Member Lifetime Gold Member

    Messages:
    4,447
    Likes Received:
    0
    Joined:
    Dec 17, 2004
    Location:
    Acton, CA
    It is, I found that a little while ago when I was seeing if anyone else had been screwed over by this guy. I am in the process of trying to get a credit card record and get in contact with the investigator to see if anything can be done.
     
  10. 77LT1

    77LT1 Veteran Member Lifetime Gold Member

    Messages:
    719
    Likes Received:
    1
    Joined:
    Jan 29, 2007
    Location:
    Jax, FL
    I'm glad to hear you got it running. Nothing worse than trying to figure out someone else's screwup.


    B
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.