new motor tuning issue

Discussion in 'Engine Topic' started by 73RATTYZ28, Jul 11, 2019.

  1. 73RATTYZ28

    73RATTYZ28 Veteran Member

    Messages:
    436
    Likes Received:
    4
    Joined:
    Feb 23, 2001
    Location:
    White Plains NY USA
    got my blueprint 383 in and its running ok. good oil pressure and runs cool. It doesnt seem to like any initial timing above 10" and runs rough off idle when i set it a 12. Runs better with the vacuum advance disconnected. Not loving the vacuum either its 12' at idle. Roller cam version. Sound like a vacuum leak?

    any thoughts appreciated.
     
  2. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    Messages:
    10,063
    Likes Received:
    371
    Joined:
    Nov 4, 2004
    Location:
    Ringgold, GA
    What Blueprint 383 is this, there are several. Might be that 12" vacuum is all you're going to get, depending on engine setup. And do you know total timing without vacuum advance.
     
  3. Lowend

    Lowend Administrator. .a car, a man, a maraca. Staff Member Lifetime Gold Member

    Messages:
    14,860
    Likes Received:
    395
    Joined:
    Mar 25, 1999
    Location:
    San Jose, CA, USA
    Are you saying the engine isn't running well with initial timing at 12 deg BTDC? That's way too much for most engines.
    I'd be shooting for 4-8 deg BTDC initial timing
    Total timing of 32 deg @ 2500 RPM is a good benchmark
     
  4. COPO

    COPO Veteran Member Lifetime Gold Member

    Messages:
    17,299
    Likes Received:
    505
    Joined:
    Sep 15, 1999
    Location:
    Toronto, Ontario, Canada
    Sounds like you need a limited plate in the distributor vacuum advance arm. Your lucky you have 12" of vacuum at idle, I have 10". Forget about initial timing, get your total set between 34-36 degrees with VA plugged at 3000-4000 rpm or whenever it stops advancing.
     
  5. tom3

    tom3 Veteran Member

    Messages:
    11,668
    Likes Received:
    264
    Joined:
    Aug 1, 1999
    Location:
    ohio
    Try ported vacuum connection? Cam manufacturer recommendation for initial timing?
     
  6. 73RATTYZ28

    73RATTYZ28 Veteran Member

    Messages:
    436
    Likes Received:
    4
    Joined:
    Feb 23, 2001
    Location:
    White Plains NY USA
    Thanks for the thoughts. Always ran my big block at 12" with vacuum advance plugged. That's what I'm at now without vacuum advance hooked up. Hard to start when hot too. This is the aluminum head roller 383. Runs better with vacuum adv plugged. Surging at 2K with it hooked up. Motor came with carb and distributor so thought it would plug and play
     
  7. 73RATTYZ28

    73RATTYZ28 Veteran Member

    Messages:
    436
    Likes Received:
    4
    Joined:
    Feb 23, 2001
    Location:
    White Plains NY USA
    Blueprint website says 10-16" 34 total. Don't think it should running this way at 12"
     
  8. G72Zed

    G72Zed Veteran Member

    Messages:
    838
    Likes Received:
    159
    Joined:
    Sep 8, 2015
    Location:
    Canada
    Was it dyno tested and tuned with the carb and distributor? if so, they should have the specs included, if not, you need to dial in the distributor advance curve correctly and also perhaps set the vacuum advance limit so you can use it, then carb setup/tuned right.
     
  9. COPO

    COPO Veteran Member Lifetime Gold Member

    Messages:
    17,299
    Likes Received:
    505
    Joined:
    Sep 15, 1999
    Location:
    Toronto, Ontario, Canada
    Put a timing light on it with the vacuum advance connected and I bet your in the 30's.
     
  10. 73RATTYZ28

    73RATTYZ28 Veteran Member

    Messages:
    436
    Likes Received:
    4
    Joined:
    Feb 23, 2001
    Location:
    White Plains NY USA
    What should it be with the vacuum advance hooked up? +- 10"? I will check.
     

Share This Page



  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.