Radio Noise Help Needed.

Discussion in 'Car Audio, Electronics & Security' started by slayer021175666, Aug 25, 2016.

  1. RLL Z-28

    RLL Z-28 Veteran Member

    Messages:
    188
    Likes Received:
    6
    Joined:
    Jul 2, 2013
    Location:
    Chattanooga,Tennessee
    lol I'm with ya bud, all I know is it's all about static electricity and that is the reason the GM engineers put it on there. Like I said just something else for you to ponder on, don't know if it's your issue or not. I had noise and not the reving kind and it worked for me.
     
  2. slayer021175666

    slayer021175666 Veteran Member

    Messages:
    1,217
    Likes Received:
    60
    Joined:
    Feb 29, 2016
    Location:
    Idaho
    Ya. I'm laughing about it, too. At this point I could laugh or cry! hahahahahaha!
    I guess there's no need to know why. If it works, it works! Thanks a lot, though!
     
  3. Z73

    Z73 Veteran Member

    Messages:
    137
    Likes Received:
    2
    Joined:
    Jul 21, 2012
    Location:
    woodstock,IL
    Just wondering if you ever found the problem cause I have the Exact problem with my car?
     
  4. Twisted_Metal

    Twisted_Metal Administrator Staff Member Lifetime Gold Member

    Messages:
    26,954
    Likes Received:
    933
    Joined:
    Feb 26, 2004
    Location:
    Bloomington, MN
    I had a "buzz" in my old Pioneer deck.
    If you powered it up, engine on or off, it was there..... But I only heard it at very low radio volume.

    Last fall, one of the display lights burned out. :(

    I ordered some tiny little bulbs and when I had the radio open to replace them, I soaked the Volume/Fader control with electronic cleaner.

    Upon reinstallation... No more "buzz"! :D
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.