1970 defogger switch

Discussion in 'Camaro Questions' started by ralph amitrano, Apr 29, 2020.

  1. ralph amitrano

    ralph amitrano Member

    Messages:
    96
    Likes Received:
    5
    Joined:
    Dec 15, 2017
    Is the switch supposed to spring back when you let go of the switch or should it stay in hi or lo position. becouse mine springs back in the off position. Is their a problem with my switch .
     
  2. BillyDean7173

    BillyDean7173 Veteran Member

    Messages:
    2,102
    Likes Received:
    607
    Joined:
    May 21, 2014
    Location:
    Hutto, TX
    The defogger switches I have all stay in the hi or lo position. They are not installed, so they are not getting electricity. I've never had one spring back to the off position.
     
  3. ralph amitrano

    ralph amitrano Member

    Messages:
    96
    Likes Received:
    5
    Joined:
    Dec 15, 2017
    Thanks Billy i just order a new one
     
    BillyDean7173 likes this.
  4. BillyDean7173

    BillyDean7173 Veteran Member

    Messages:
    2,102
    Likes Received:
    607
    Joined:
    May 21, 2014
    Location:
    Hutto, TX
    You're welcome. The ones I have look like the end of the toggle switch was hit with the lighter . . . multiple times, lol. I had a hard time finding one for my 73Z without any damage or discoloration. One thing I seem to recall was that there's difference in the pins or circuit board between some of them. It could have been repop vs. OEM, I just can't remember.

    Well, I found the difference at least according to Camaro Central. See the note they have.
    https://www.camarocentral.com/1970_1978_Camaro_Rear_Window_Defog_Defrost_Dash_p/das-483.htm
     

Share This Page