1973 Z28 Doesn't have fire.

Discussion in 'Troubleshooting & Diagnosis' started by Jhboy10, Nov 19, 2014.

  1. COPO

    COPO Veteran Member Lifetime Gold Member

    Messages:
    21,042
    Likes Received:
    2,581
    Joined:
    Sep 15, 1999
    Location:
    Ontario, Canada
    Did you connect the dist black wire that runs from the advance plate to the front vacuum advance mounting screw?
    This one in the pic is loose. Also a black wire runs from the points to the - side of the coil.

    [​IMG]
     
    Last edited: Nov 22, 2014
  2. Jhboy10

    Jhboy10 New Member

    Messages:
    16
    Likes Received:
    4
    Joined:
    Nov 19, 2014
    Location:
    Rabun County,GA
    I finally got it to work. Ended up changing Rotor button and points and it fired. Then I hooked a gas tank to the carb and it started leaking out around the accelerator pump. Anyways thanks for the ideas hopefully soon ill take the carb part and replace some gaskets. BTW any good/cheap places to get gaskets or a rebuild kit for a Holley 4160?
     
  3. Alyx

    Alyx New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Aug 7, 2009
    Location:
    Fairbanks Alaska
    I have a rebuild kit for an old 650 double pumper holley, I can check and see if it was the 4160... it's from back when I was still a teenager.... bought the kit for like $25, then sold the car before I could install it...
     
  4. COPO

    COPO Veteran Member Lifetime Gold Member

    Messages:
    21,042
    Likes Received:
    2,581
    Joined:
    Sep 15, 1999
    Location:
    Ontario, Canada
    Summit http://www.summitracing.com/int/sea...rtOrder=Ascending&keyword=holley 4160 rebuild or your local Speed Shop. Last time I just bought the parts individually cause the kits have more than your model will need.
     
  5. Jhboy10

    Jhboy10 New Member

    Messages:
    16
    Likes Received:
    4
    Joined:
    Nov 19, 2014
    Location:
    Rabun County,GA
    Thanks im probably gonna have a family friend rebuild it. Finally got another carb to test with and the car will run off what you spray in it but wont stay running. Gonna try a good carb and new plugs, wires, and rotor button and points.
     

Share This Page