1981 Z28 Lq4

Discussion in 'High Tech Retrofits' started by Zedzag, Mar 3, 2011.

  1. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    After a long break from working on my swap, here'a an update with a little teaser vid. I can't wait to get this thing back on the ground!

    I did a bunch of re-wiring in the engine compartment(I HATE wiring) and moved the relays and fuses to above the heater box. I'm using a Techrods harness which is not vehicle specific and it's been a challenge to hide the extra length. Here's a some pics.

    [​IMG]
    [​IMG]
    Here's the vid.
    http://www.youtube.com/user/zedzag#p/a/u/0/aTo2LWrk1yY
     
  2. BLKnBad71Z

    BLKnBad71Z Veteran Member

    Messages:
    1,431
    Likes Received:
    1
    Joined:
    Sep 20, 2000
    Location:
    Buffalo,NY,USA
    Sounds good! What do you have in the motor??
     
  3. SupplySgt

    SupplySgt Veteran Member Lifetime Gold Member

    Messages:
    1,393
    Likes Received:
    12
    Joined:
    Jun 20, 2009
    Location:
    Central OK
    Nice. I'll watch the video when I get home.
     
  4. mrvedit

    mrvedit Veteran Member

    Messages:
    1,357
    Likes Received:
    4
    Joined:
    Jun 12, 2009
    Location:
    Ann Arbor, MI
    What and where did you get the tight 90 degree bends for the heater hoses? I know others have asked about this too. I ripped the short tubes out of the water pump and pipe threaded the holes, but it isn't an ideal solution. What you did looks better.
    Also what upper radiator hose did you use?
    I don't see a connection for the steam line - I connected mine to the hose between the overflow tank and radiator.
     
    Last edited: Mar 3, 2011
  5. DirtyScotty

    DirtyScotty Veteran Member

    Messages:
    814
    Likes Received:
    0
    Joined:
    Jan 27, 2004
    Location:
    Caledonia. Ont. Communist Canada
    What motor mounts are you using? and oil pan?
     
  6. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    It's been a budget rebuild so far. I put in new standard bore speedpro hypereutectics with a TSP ported oil pump, Rollmaster billet chain and ARP everywhere. It's 2001 so it has the 317 aluminum heads which were milled .020, new stock valves with Crane dual springs for the 228/232 cam. It has less than 500 miles on it.
     
  7. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    I'm using Street&Performance adapters with the stock 1981 clamshell upper and lower mounts. The oil pan is f-body.
     
  8. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    Here's what I'm using for heater hoses and rad hoses:
    Larger heater hose - Dayco P/N 80416
    Smaller heater hose - Dayco P/N 80405
    Rad upper - Gates P/N 20893
    Rad lower - Dayco P/N 71391

    Remember, these are for an fbody waterpump to STOCK 1981 Z28 3 core rad and stock 1981 Z28 heater core. Any other variables may not work out. I'm not sure f 1980 or 1979 cars had the same rads or heater cores.
     

Share This Page