AC Vacuum Hose Firewall Grommet Fail, Need Some Ideas

Discussion in '1970 - 1973 Specific' started by Randy S, Aug 16, 2016.

  1. Randy S

    Randy S Veteran Member

    Messages:
    164
    Likes Received:
    0
    Joined:
    Mar 27, 2008
    Location:
    NELA
    This is on my '72. I finally made some time to get back in the shop and start working on the A/C. Vacuum hose connections are on the 'to do list'. I noticed that the pair of hoses that come through the firewall (via a grommet) next to the evaporator suitcase were pushed back through the firewall into the underdash area. :mad:

    I was able to snake some baling wire through the hole and pull them back into the engine bay, but can't think of a good way to re-seat the grommet. I'm concerned that if I pull on the hoses, they'll separate. Can't get my arm on top of the underdash box to push it through.

    Anybody know a trick to pull it through or am I looking at a dash pull? :-/
     
  2. FredG70SS

    FredG70SS Veteran Member

    Messages:
    160
    Likes Received:
    1
    Joined:
    Dec 3, 2005
    Location:
    Burlington, Ontario
    I had the same problem but fixed it from the inside. You will have to remove the lap vent, the glove box and the flexible duct to the side dash vent. With that out of the way you will be able to reach the grommet.
     
  3. Randy S

    Randy S Veteran Member

    Messages:
    164
    Likes Received:
    0
    Joined:
    Mar 27, 2008
    Location:
    NELA
    Good guidance; thank you. I'll tackle it again this weekend.
     

Share This Page