Anyone running the GMPP LS3-480 crate engine?

Discussion in 'High Tech Retrofits' started by 1934chevycoupe, Sep 6, 2021.

  1. 1934chevycoupe

    1934chevycoupe Veteran Member

    Messages:
    325
    Likes Received:
    7
    Joined:
    Mar 12, 2013
    Location:
    Harleysville, Pa
    Anyone running the GMPP LS3-480 crate engine w/ the hot cam? Getting ahead of myself, but where does the vacuum hose from the brake booster go to on the engine, and is there enough vacuum from the engine w/ the hot cam? FYI, the cam specs are .525" lift intake & exhaust, 219* intake & 228* exhaust duration w/ 112 LSA.
     
  2. mrfleet12

    mrfleet12 Veteran Member

    Messages:
    988
    Likes Received:
    654
    Joined:
    Aug 8, 2014
    Location:
    West of Chicago IL
    On my LS2 I ran it to a port in the back of the intake.
    Not sure about your cam.
     
    1934chevycoupe likes this.
  3. 73Z L92

    73Z L92 Veteran Member

    Messages:
    291
    Likes Received:
    113
    Joined:
    Jan 25, 2011
    Location:
    Carlos, MN
    I've run a couple of L92 (6.2) swaps with 225I/230E .600 lift 114 C/L aftermarket cams Texas Speed with power brakes with no issues. My current 80 Camaro project with a L92 is running the cam listed above (not running yet)and I don't anticipate any issues. The 112 c/l on your cam will give you a bit more chop at idle.
     
    1934chevycoupe likes this.
  4. streak

    streak Member

    Messages:
    37
    Likes Received:
    11
    Joined:
    Apr 27, 2021
    It's still a baby cam with tons of vacuum. Heck my .600 lift cam is considered tiny but fits my racing use.
     
    1934chevycoupe likes this.
  5. 76z28

    76z28 Veteran Member

    Messages:
    2,392
    Likes Received:
    183
    Joined:
    Jun 29, 2009
    Location:
    bakersfield
    It's a great engine. Have a friend with one. I wouldn't mind one for my 68 but I may go with a BluePrint 400 for ease of swap/power. I want to go not block not dang... That car has a tiny engine bay.
     
  6. Pierre74LT

    Pierre74LT Member

    Messages:
    40
    Likes Received:
    8
    Joined:
    Dec 28, 2012
    Location:
    Qc
    I have a 376-480 in a l92 the engine is running but the car is still in restoration. The vacuum is at 14 at idle. DSCN0837.JPG the power brake hose is is the port in the back of intake. DSCN0836.JPG
     
    1934chevycoupe likes this.
  7. AlbertaZ28

    AlbertaZ28 Veteran Member

    Messages:
    299
    Likes Received:
    9
    Joined:
    Aug 17, 2010
    Location:
    Fort Mcmurray, Alberta
    I have the Ls 376/480 in my 1980 Camaro. Lots of vacuum to run the brakes. It's been a while but I'm pretty sure there was an adapter required to connect the brake booster hose.
     
    1934chevycoupe likes this.
  8. Joekool

    Joekool Veteran Member

    Messages:
    5,924
    Likes Received:
    36
    Joined:
    Feb 4, 2002
    Location:
    Hollister CA USA
    The LSA is about as low as you can go with an EFI LS but the cam isn't all that big otherwise so it should produce decent vacuum at idle.
     
    1934chevycoupe likes this.

Share This Page