Briggs and Stratton ?

Discussion in 'The BS Topic' started by BigBlock73, Dec 1, 2008.

  1. BigBlock73

    BigBlock73 Veteran Member Lifetime Gold Member

    Messages:
    2,179
    Likes Received:
    99
    Joined:
    Jul 10, 2002
    Location:
    Accord,New York
    I borrowed a log splitter from a friend.
    It would only run with the choke on full
    It's a 8 HP IC
    It would start and run but if I moved the choke from full it would stall.Even when warmed up.
    I changed the fuel filter
    It has low hours
    He said it has always been like this
    Air filter is clean
    Any ideas
     
  2. rscamaro73

    rscamaro73 Administrator Staff Member

    Messages:
    14,977
    Likes Received:
    17
    Joined:
    May 30, 1999
    Location:
    Striking fear and destroying the enemy
    Is the choke 'wrong' as in full choke is 'no' choke ? Has someone physically verified ? I've seen a few labeled wrong (or the owner told me the wrong thing).

    Jets needing adjustment is another thing. Put a fresh plug in, screw the IDLE screw in all the way (softly) and screw it out 2.5 times. Count the times it takes to go in as reference. Also verify the hi speed screw as well (turns to seat).

    Might be a broken govenor.....had that happen once.....motor RPM's never varied....it just ran WFO all the time, no lo speed at all.
     
  3. -=79z28=-

    -=79z28=- Veteran Member Lifetime Gold Member

    Messages:
    1,342
    Likes Received:
    0
    Joined:
    Jan 22, 2008
    Location:
    Charlotte, NC
    if its always been like this, i'd venture a guess its a defect in the carb. if its always done this, why didn't he get it looked at considering it was brand new?
     
  4. Twisted_Metal

    Twisted_Metal Administrator Staff Member Lifetime Gold Member

    Messages:
    29,921
    Likes Received:
    2,693
    Joined:
    Feb 26, 2004
    Location:
    Bloomington, MN
    If it only runs on full choke.... it's not getttng enough fuel when you take the choke off.

    This is usually a fuel mixture problem (lean), not an air cleaner, spark plug or fuel filter issue.
    There should be a single mixture screw on the carb.... Back it out a half turn and try it again.

    Sometimes a spec of junk will find it's way to the needle valve and shut down the fuel flow enough to cause a problem like this.

    Follow Wayne's directions above.

    I've pulled these little carbs apart, found absolutely nothing wrong (cleaned it anyway) and they an perfectly whafter reassembly. :confused:
    They're pretty simple.... Don't be afraid to take the carb apart if the mixture screw adjustment doesn't help you out.

    Good luck!
     
  5. kik_start

    kik_start BANNED

    Messages:
    3,296
    Likes Received:
    0
    Joined:
    Sep 3, 2006
    Location:
    gone crazy
    getting air from somewhere other than the carb...intake gasket might be bad.

    carb gasket...not intake..(thinking of SBC) haha...bolts tight? leaks around the throttle shaft....
     
    Last edited: Dec 1, 2008
  6. BigBlock73

    BigBlock73 Veteran Member Lifetime Gold Member

    Messages:
    2,179
    Likes Received:
    99
    Joined:
    Jul 10, 2002
    Location:
    Accord,New York
    I pulled the air filter
    Verified the choke is working and on full
    Governor is working,big log and rpm's go up
    Played with the 1 adjustment I could find and it made no change.
    I want to tell him he has a bad carb. and needs to replace it but don't want him to waste money
     
  7. BigBlock73

    BigBlock73 Veteran Member Lifetime Gold Member

    Messages:
    2,179
    Likes Received:
    99
    Joined:
    Jul 10, 2002
    Location:
    Accord,New York
    Sprayed carb cleaner all around intake while it was running = no change
    Can't explain why he didn't bring it back when new,it still works but not as well as it should
     

Share This Page