fast ez efi problem

Discussion in 'High Tech Retrofits' started by garyandcindy, Nov 30, 2013.

  1. Leonards78LT

    Leonards78LT Veteran Member Lifetime Gold Member

    Messages:
    1,031
    Likes Received:
    0
    Joined:
    Jan 21, 2001
    Location:
    Central Oklahoma

    One thing you could check is your grounds. Make sure you have good solid connections.
    Battery to engine block
    Battery to frame.
    Engine block to body
    Frame to body.

    Surfaces must be clean of all paint, grease, etc., and use star washers to insure a good bite to the metal.
     
  2. BonzoHansen

    BonzoHansen Administrator Lifetime Gold Member

    Messages:
    20,074
    Likes Received:
    1,403
    Joined:
    Jun 1, 2005
    Location:
    Scott from Hamilton, NJ
    triple check for vacuum leaks too.

    is there anyway this is an ignition issue?
     
  3. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,619
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    All grounds should be good.Was not having any problems until I installed this system.
     
  4. BonzoHansen

    BonzoHansen Administrator Lifetime Gold Member

    Messages:
    20,074
    Likes Received:
    1,403
    Joined:
    Jun 1, 2005
    Location:
    Scott from Hamilton, NJ
    EFI is far more ground finicky than what you had before. Do not assume, double check.
     
  5. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,619
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    Wouldn't think that ignition or vacuum leaks would be an issue.This thing ran great for about 3 weeks/150 miles.But you never know.It's not like it slowly sputters and dies.If you let it get below about 1300 rpm's it's like you turned the switch off.
     
  6. BonzoHansen

    BonzoHansen Administrator Lifetime Gold Member

    Messages:
    20,074
    Likes Received:
    1,403
    Joined:
    Jun 1, 2005
    Location:
    Scott from Hamilton, NJ
    it seems you are waiting anyway. get checking. and grab some new plugs

    what kind of distributor are you running?
     
  7. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,619
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    Gm performance dizzy.I'm gonna wait and let them tell me what to do.I paid too much money for this to try and trouble shoot it myself.I just don't think it's ground related.Besides shouldn't I be having other issues if I had a bad ground?I mean it ran great one second and went to crap the next.I can't help but think something electrical went bad with the system.If I have to trace grounds later then I will.This is just so disappointing at this point.
     
  8. DFWJ

    DFWJ Veteran Member

    Messages:
    300
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    Location:
    DFW

    You need to take the car to an efi tuner, since you seem to not want to check the basics of an internal combustion engine.



    Waiting for FAST Tech Support to tell you what to.... Lol


    Let me guess, in two months you're going to go back to a carb and say the EZ-EFI was junk.
     
  9. Leonards78LT

    Leonards78LT Veteran Member Lifetime Gold Member

    Messages:
    1,031
    Likes Received:
    0
    Joined:
    Jan 21, 2001
    Location:
    Central Oklahoma
    Making assumptions that it may not be not the problem. I'm done :confused:
     
  10. garyandcindy

    garyandcindy Veteran Member

    Messages:
    1,619
    Likes Received:
    6
    Joined:
    Oct 20, 2004
    Location:
    cumming,ga-usa
    So I'm supposed to just dive in and start screwing around with the efi and possible void any warranty it has.THEY say it's the IAC so i'll let them tell me if that's the problem.If that's not it then i'll let them tell me what they think it is.Two grand for a system that is all about electronics.I'm messing with nothing other than what they say too for now.I'll start doing the things yall are suggesting once fast comes to a dead end.And as far as taking it to a efi tuner,The guys that installed this for me are as good a mechnics as you will find anywhere.Bar none.And they are saying to wait and see what fast comes up with then we''ll check it out once fast can't find the problem.
     
    Last edited: Dec 4, 2013

Share This Page