Found the 12's! 12.24@111.38!

Discussion in 'Competition Camaros' started by flak monkey, Jul 31, 2016.

  1. flak monkey

    flak monkey Veteran Member Lifetime Gold Member

    Messages:
    1,064
    Likes Received:
    4
    Joined:
    Aug 5, 2011
    Location:
    Norfolk, UK
    Thanks. That's interesting to hear for sure!
    Here's my intake:

    [​IMG]

    [​IMG]
     
  2. flak monkey

    flak monkey Veteran Member Lifetime Gold Member

    Messages:
    1,064
    Likes Received:
    4
    Joined:
    Aug 5, 2011
    Location:
    Norfolk, UK
    Crap times today, very slippery track and a 40mph head wind probably didn't help at all.

    12.96@109.11 was the best effort. ET was 0.7 down on my PB and 2mph short too.

    Just could not get traction at all today - and it wasn't just me....

    I did get a couple of nice photos from Blackett Photography though...

    [​IMG]

    [​IMG]
     
  3. mrdragster1970

    mrdragster1970 Veteran Member Lifetime Gold Member

    Messages:
    7,821
    Likes Received:
    507
    Joined:
    Apr 12, 2007
    Location:
    Chicago, Illinois..... Far S.W. Subs, RT 66 Area
    .


    That wheel-tire combo looks wrong.
    Not enough wrinkle has to be killing the 60.


    .
     
  4. flak monkey

    flak monkey Veteran Member Lifetime Gold Member

    Messages:
    1,064
    Likes Received:
    4
    Joined:
    Aug 5, 2011
    Location:
    Norfolk, UK
    It's just on street tires - I still haven't sorted any drag radials for it...

    My best 60' on those is 1.77 - and I was consistently running 1.7's last time I was out as well. But that was on a pro-prepped track and on a much hotter day.

    Exactly the same set up today and unable to get anything under 2.1 sec 60'

    Everybody in our club was suffering the same issues - around 1 sec slower ET and 3-5mph down on speed - all had traction issues including those on slicks. No glue on the track at all.

    [youtube]D-ASppV_Jcc[/youtube]
     
  5. mrdragster1970

    mrdragster1970 Veteran Member Lifetime Gold Member

    Messages:
    7,821
    Likes Received:
    507
    Joined:
    Apr 12, 2007
    Location:
    Chicago, Illinois..... Far S.W. Subs, RT 66 Area
    .


    That's kind of weird, usually as the 60 goes up, the MPH goes up.
    40 MPH is frigging crazy high, so that has to be an issue.

    I've been on some pretty greasy tracks, with insane DA, and I never lost 1 second.
    Even on no prep nights, 1 second is huge.
    I wonder if something was jacked up in the timing???

    At least you didn't hurt anything, and hopefully you guys had fun.


    .
     

Share This Page