Hedman Elite Heavy-Duty Headers 67278

Discussion in 'Engine Topic' started by sam73, May 24, 2021.

  1. sam73

    sam73 New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Oct 29, 2015
    Location:
    Haskell
    Just installed a set of Hedman 67278 on my 73 RS. Not sure I like the fit on the driver side from the underneath. The collector is pointing slightly down, rather than running parallel with the floor board. Look the pic from the underneath and you can see the difference between the right and left side. I called Hedman. Explained the situation and also sent pictures. DavidC at Hedman agreed with me that the driver side is hanging slightly lower that the passenger side. DavidC stated that there was nothing his company could do to resolve this issue. Just the way it is. Your opinion?
     

    Attached Files:

  2. Rosster

    Rosster Veteran Member Gold Member

    Messages:
    552
    Likes Received:
    264
    Joined:
    Mar 1, 2020
    Completely unacceptable! I’d ship them back (on their dime). Obviously they don’t give a crap about quality if they just blew you off like that!
     
    Zstar likes this.
  3. Green hornet

    Green hornet Veteran Member

    Messages:
    2,021
    Likes Received:
    470
    Joined:
    Oct 11, 2015
    Location:
    North Bay, CA
    I put a set of Headman 68278 on a few years ago. Here’s a photo of the fit.

    BC3DD850-02F8-43BA-BD19-220578D924EC.jpeg
     
  4. Crazy4camaro

    Crazy4camaro Veteran Member

    Messages:
    462
    Likes Received:
    254
    Joined:
    Dec 30, 2015
    Location:
    Greenville SC
    Send them back...
     
  5. camaro71/holland

    camaro71/holland Veteran Member

    Messages:
    1,494
    Likes Received:
    196
    Joined:
    Aug 27, 2003
    Location:
    The Netherlands
    Put a level across the top of your intake. On your 2nd pic it looks like the left/driver side of your transmission pan is hanging lower too.
     
  6. Zstar

    Zstar Veteran Member

    Messages:
    2,538
    Likes Received:
    848
    Joined:
    Mar 23, 2014
    Location:
    Ocala, Florida
    I had this same problem with the same headers on my 73. I have an M21. The cure was to install a new rear transmission mount. Problem solved. You may also have a problem with your left engine mount.
     
  7. sam73

    sam73 New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Oct 29, 2015
    Location:
    Haskell
    Holland--Zstar, you are correct. Looking at the pics, the transmission is hanging lower on the left. I will be in the shop tomorrow evening to investigate. I am surprised that the tech at Hedman did not see this. As noted, an issue with the motor mounts or transmission bracket/mount. Thanks guys
     

Share This Page