It's alive! Wooo Hooo!

Discussion in 'High Tech Retrofits' started by Zedzag, Jun 30, 2009.

  1. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    The LQ4 is alive again and this time it's injected! After a lot of searching and sourcing parts, I finally got everything I needed to start up the beast with factory EFI. This was a major hurdle as I had nothing to start with(long block only) and I'm relatively EFI inept. She still doesn't idle unless I crack the throttle and raise the RPM to around 1000 but that may be due to the stock tune and my 228/232 cam. Maybe I have to drill the throttle plate?
    I'll see if I can get a vid up soon.
     
  2. Dangerous Drew

    Dangerous Drew Veteran Member

    Messages:
    322
    Likes Received:
    0
    Joined:
    Feb 11, 1999
    Location:
    Waco, TX
    Congrats.

    I'd try to fix it in programming. Don't drill the throttle body blade; from what I've heard it's not easy to find replacements. ;) What PCM are you running?
     
  3. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
    I'm using a foctory 2000 LS1 6spd pcm. I'll get my buddy with HP tuners down to see if he can tune it up...it needs it!
     
  4. Dangerous Drew

    Dangerous Drew Veteran Member

    Messages:
    322
    Likes Received:
    0
    Joined:
    Feb 11, 1999
    Location:
    Waco, TX
    Yeah, that cam's not terribly big, ought to tune right up. Pull a little fuel at idle in the VE table, bump the idle up a bit, oughta run fine.
     
  5. Zedzag

    Zedzag Veteran Member

    Messages:
    528
    Likes Received:
    0
    Joined:
    Jan 27, 2002
    Location:
    Vancouver,B.C.,Canada
  6. POS71RS

    POS71RS Moderator Staff Member Lifetime Gold Member

    Messages:
    10,327
    Likes Received:
    5
    Joined:
    Aug 21, 2002
    Location:
    Central Coast, CA
    ooooooooooh... them vids are sexy.... that thing sounds great!
     
  7. Aceshigh

    Aceshigh Veteran Member Lifetime Gold Member

    Messages:
    26,757
    Likes Received:
    6
    Joined:
    Apr 9, 2001
    Location:
    Boondocks
    I just have one question.

    Where do I get a pair of snazzy socks and thongs like that?? :crazy:
    Just kidding.

    EFI is nice isn't it. :cool: I have an LS1 in mine also.
    Why did you go carbed in the first place anyways??
     
  8. scrapmetal

    scrapmetal Veteran Member Lifetime Gold Member

    Messages:
    1,811
    Likes Received:
    79
    Joined:
    Jul 5, 2007
    Location:
    Cleburne,Texas
    Sounds nice!
     
  9. John Wright

    John Wright Veteran Member Lifetime Gold Member

    Messages:
    15,122
    Likes Received:
    361
    Joined:
    Aug 9, 2002
    Location:
    Rustburg, Va
    Plus One!....save the drilled holes for throttle blades in carbs...LOL


    Congrats on getting the beast up and running on EFI.
     
  10. 1st and goal

    1st and goal Veteran Member

    Messages:
    400
    Likes Received:
    0
    Joined:
    Nov 5, 2005
    Location:
    Seacoast, NH
    Nice, sounds good :bowtie:
     

Share This Page