MSD 6 AL Question

Discussion in 'Engine Topic' started by Rdobbs1977, May 6, 2015.

  1. Rdobbs1977

    Rdobbs1977 Huge Guns N Roses Fan

    Messages:
    342
    Likes Received:
    23
    Joined:
    Dec 1, 2014
    Location:
    Nashville
    In an earlier post I reported that I had an idle problem and will die if it goes below around 1200 RPMs. I'm still working to figure this problem out. I've done a lot of my own diagnostics (still have one or two more that I have yet to run) and have done a tune up on the car. One thing I thought I'd run by you guys is that I have an MSD 6AL on the 350 (stock). Have any of you ever heard of an MSD box going bad? If so, what symptoms arise when this happens? Thanks,
     
  2. Throttle

    Throttle Veteran Member Gold Member

    Messages:
    1,342
    Likes Received:
    4
    Joined:
    Feb 2, 2002
    Location:
    Dripping Springs ,Texas........USA
    I have had a box go bad on me, it just didnt start once it took a crap. Your problem doesnt sound like an MSD problem.
     
  3. DFWJ

    DFWJ Veteran Member

    Messages:
    300
    Likes Received:
    0
    Joined:
    Aug 16, 2012
    Location:
    DFW
    I've had a 6al go out, after burning two boxes and an ignition driver in an AEM ems.
    Tracked that problem back to crappy wiring by my room mate.

    The box is usually all or nothing. I'd suspect something else.
     
  4. Rdobbs1977

    Rdobbs1977 Huge Guns N Roses Fan

    Messages:
    342
    Likes Received:
    23
    Joined:
    Dec 1, 2014
    Location:
    Nashville
    10-4, thanks for the feedback
     
  5. gordonquixote

    gordonquixote Veteran Member Lifetime Gold Member

    Messages:
    3,022
    Likes Received:
    11
    Joined:
    Jul 18, 2006
    Location:
    Tallahassee, FL
    It's possible that you have a bad ground or poor power source To your distributor and it isn't throwing spark at low RPM.

    I had a stupid Mallory that I bought on here used do that (and burn modules).

    You can pull the distribitor and spin itby hand to see what's up.

    BUT....a car the wont idle at low RPM often is just a vacuum leak and/or retarded timing.
     

Share This Page