My 80 Z Clone (Pic Heavy)

J. Chris Davis

Veteran Member
Jul 13, 2004
865
Dixon, IL USA
Just a small updated. Worked on the car this weekend and yesterday since I had the day off of work. I'm in the process of ordering the correct brake hoses for the front. The ones from Summit were too short. I have a call into Keith with Custom Works about ordering the conversion hoses they have. I have everything just about painted. So hopefully this weekend I can get it back together.
 

J. Chris Davis

Veteran Member
Jul 13, 2004
865
Dixon, IL USA
Got some updates from tonight. Finally got the upper and lower control arms installed. Bolts are loose until I can get the car on the ground to torque everything. If someone can answer this about the upper ball joint. After I installed them I noticed in pictures I was using for reference that I didn't see the lock washer under the bolt head like how I have them installed. Did I do this correctly or are the lock washers supposed to go on under the nut?


20150407_180025.jpg


20150407_184831.jpg


20150407_184858.jpg


20150407_194327.jpg


20150407_195950.jpg


20150407_200014.jpg


20150407_200103.jpg
 
Last edited:

J. Chris Davis

Veteran Member
Jul 13, 2004
865
Dixon, IL USA
Ok, thanks. I can get them flipped around real quick tomorrow before I start the other stuff. I didn't notice till I was sitting down at my computer. I also question the 10 ft ibs of torque required for the upper ball joint bolts and nuts. Seems they should be a lot tighter.
 
Last edited:

J. Chris Davis

Veteran Member
Jul 13, 2004
865
Dixon, IL USA
Looks I need to get a couple 1/8" wheel spacers for the fronts. When I put the wheels on they hit the face of the caliper. Should have those in a couple of days and then I can put the wheels back on.
 




Latest posts

Top