P0449 code on 08 Trailblazer

Discussion in 'The BS Topic' started by CorkyE, Jan 22, 2020.

  1. Mike N

    Mike N Administrator Staff Member Lifetime Gold Member

    Messages:
    2,912
    Likes Received:
    633
    Joined:
    Jan 13, 2002
    Location:
    Spencerport, NY.
    449 is an open or short in the vent solenoid circuit. 99% of the time we find the solenoid itself is junk.

    Iirc it's mounted above the spare tire on that model.
     
    gramps likes this.
  2. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    Messages:
    10,999
    Likes Received:
    724
    Joined:
    Nov 4, 2004
    Location:
    Ringgold, GA
    Don't know for sure where it's mounted on the Trailblazer, guess I'll find out. From what I've been reading, it's likely the solenoid. I ordered one (GM brand) from Rock Auto so I'll toss it in when it gets here. I checked the gas tank cap, gasket looked okay. I sprayed and wiped some Fluid Film on the gasket just for S & G's. This car has never been in salt or snow, so it's not gunked up underneath. Thanks Mike, I really thought this would be an O2 sensor issue. :D
     
    xten likes this.
  3. Knuckle Dragger

    Knuckle Dragger Mayor of Simpleton Staff Member Lifetime Gold Member

    Messages:
    15,987
    Likes Received:
    2,354
    Joined:
    Nov 2, 2002
    Location:
    Waddell AZ
    I'm sure it still needs one.

    FYI, if it was the cap you would have got a code for a leak. I think the valve will fix it. On the full size stuff the updated solenoid requires a jumper harness because the connector changed. So if it's looks wrong that might be the case here too.
     
  4. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    Messages:
    10,999
    Likes Received:
    724
    Joined:
    Nov 4, 2004
    Location:
    Ringgold, GA
    I saw a Utube video, pointed out the updated part, hopefully it will plug and play. Thanks
     
  5. camarolife78

    camarolife78 Veteran Member

    Messages:
    549
    Likes Received:
    7
    Joined:
    Jul 22, 2014
    Location:
    Gardner, KS
    The hard start when refueling means the valve is stuck open allowing the fuel vapors to flood the engine, thus causing the hard start. Good job in purchasing the delco brand from RA. The parts store china brand parts never last. At the shop we only use OEM emissions parts because the aftermarket never lasts.
     
    tom3 likes this.
  6. CorkyE

    CorkyE Veteran Member Lifetime Gold Member

    Messages:
    10,999
    Likes Received:
    724
    Joined:
    Nov 4, 2004
    Location:
    Ringgold, GA
    Well I initially ordered the wrong Evap Emission Solenoid. There a two of them, one on the engine and one by the gas tank. I needed one by the gas tank (ACD#25950499). I don't have a lift so it's a lot easier to access by dropping the spare tire when working on your back. Not a big deal after that. I cleared the codes and light is staying off.
     
  7. Knuckle Dragger

    Knuckle Dragger Mayor of Simpleton Staff Member Lifetime Gold Member

    Messages:
    15,987
    Likes Received:
    2,354
    Joined:
    Nov 2, 2002
    Location:
    Waddell AZ

    The one by the engine is the purge, the one in the tank is the vent. Little late now but thought maybe.......

    Glad it's fixed.
     

Share This Page