Pro Comp gas gauge not working correctly

Discussion in 'Gauge Marks' started by ZoSoIV, Sep 16, 2018.

  1. ZoSoIV

    ZoSoIV New Member

    Messages:
    29
    Likes Received:
    2
    Joined:
    Sep 16, 2018
    hey guys just bought a 1970 Z-28 , RS on the resto they used Pro Comp gauges and the gas gauge isn’t working correctly ... when full it shows just over a half tank and empty it shows around a quarter tank ... I’m trying to pin down if it’s the gauge or the gas tank float ... what should I look at first ? Thanks
     
  2. dave@ztech

    [email protected] Veteran Member Lifetime Gold Member

    Messages:
    4,645
    Likes Received:
    1,060
    Joined:
    Mar 27, 2016
    Location:
    NY
    Check the voltage, and see if the correct voltage is at the gauge , if it is then the junk in the trunk/tank is acting up
     
    hubedobeedo likes this.
  3. ZoSoIV

    ZoSoIV New Member

    Messages:
    29
    Likes Received:
    2
    Joined:
    Sep 16, 2018
    Ok thanks
     
  4. Twisted_Metal

    Twisted_Metal Administrator Staff Member Lifetime Gold Member

    Messages:
    29,692
    Likes Received:
    2,530
    Joined:
    Feb 26, 2004
    Location:
    Bloomington, MN
    The gauge is an ohm meter.
    It measures resistance in the circuit through the sending unit.

    It may simply be a mismatch between the gauge and sending unit resistance range.

    Try to find out the model of the gauge to find its intended ohm range.

    If I remember correctly... the sending unit should be 90 Ohms full and 0 Ohms empty.
     
    hubedobeedo likes this.
  5. ZoSoIV

    ZoSoIV New Member

    Messages:
    29
    Likes Received:
    2
    Joined:
    Sep 16, 2018
    Thanks
     

Share This Page