sbc no spark

david bartel

Member
Aug 9, 2017
30
I have a 1980 z-28. I just installed a new 350 crate engine. The first time I started I got spark. I needed to pull the distributor to realign. Now no spark. I have power at the distributor 12.5v. I installed a new ignition module. I checked the resistance at the coil 14k. is there any fuses that run to this? I would like to check ground but not sure how to do that. I have ground attached to the engine. What's going on. what do I check next?
 

CorkyE

Veteran Member
Lifetime Gold Member
Nov 4, 2004
11,737
Ringgold, GA
Can you borrow a know working distributor from someone? If you have power, good ignition module and coil, about the only thing left is the magnetic pick up unit. But first, go back through the distributor, make sure the button is installed correctly between the cap and coil. Make sure there is no damage to cap and rotor. Distributor should ground through the engine and hold down clamp. Sometimes it's the small things that catch us.
 

Redrod1977

New Member
May 8, 2022
19
Did you physically check for spark or just assuming? I may times had to realign the dist. And for some reason I was out 180 degrees. It was a major over look for me but once I did and I corrected it the engine start right away.
 

mech393

Veteran Member
Aug 9, 2003
892
belvidere illinois usa
when you installed the module was there a air gap to set to the distributor lobe , and i believe if you put a volt meter on the negative side of the coil and crank the engine over you should see the module pulsing as the engine turns over. showing the voltage is opening and closing like a set of points.
 




Top