Shift linkage bracket help

Discussion in 'Transmission & Driveline Topics' started by bazookatooths, Nov 29, 2019.

  1. bazookatooths

    bazookatooths Member

    Messages:
    37
    Likes Received:
    1
    Joined:
    Apr 25, 2018
    Location:
    OKC OK
    I just recently got a new TH350 and it is missing the 2 bolts for the shift linkage. I'm wondering what you guys used to fix the situation?
     

    Attached Files:

  2. 70-camaro

    70-camaro Veteran Member

    Messages:
    3,517
    Likes Received:
    1,991
    Joined:
    Mar 25, 2010
    Location:
    marietta ohio
    Looks like two different transmissions there. Mine uses two transmission pan bolts.
     
  3. rburrow87

    rburrow87 Veteran Member

    Messages:
    153
    Likes Received:
    51
    Joined:
    Apr 6, 2016
    Location:
    San Diego, CA
    Yeah that looks like the wrong bracket for a 2nd gen f-body. Should be using 2 pan bolts. I replaced mine with this and it works beautifully with the factory ratchet shifter thingy and a Shiftworks cable: https://www.summitracing.com/parts/oer-9795915/

    Pic of a factory TH350 bracket installed here: TH350 linkage help

    My original bracket ended up being correct, but it was bent. Couldn't really tell how it was supposed to look until I had the new on in front of me. It's important that the cable is at the correct angle with the correct transmission lever otherwise the shifter won't work well.
     
  4. 70-camaro

    70-camaro Veteran Member

    Messages:
    3,517
    Likes Received:
    1,991
    Joined:
    Mar 25, 2010
    Location:
    marietta ohio
    Yea. The Summit bracket looks correct.
     
  5. bazookatooths

    bazookatooths Member

    Messages:
    37
    Likes Received:
    1
    Joined:
    Apr 25, 2018
    Location:
    OKC OK
    Yes the second pic is the older transmission the two holes were in the transmission above the pan. Def not the original the car had a 70-80s 305 for a power plant.

    Nice that bracket looks like the fix! Thanks guys
     
  6. bazookatooths

    bazookatooths Member

    Messages:
    37
    Likes Received:
    1
    Joined:
    Apr 25, 2018
    Location:
    OKC OK
    Just an update I got the bracket in fit good on the transmission. The new issue is with the transmission in park and shifter, it is about 3/4" too short.

    Was thinking about going with this
    https://www.summitracing.com/parts/siw-k100-30/
     

    Attached Files:

    Last edited: Dec 5, 2019
  7. rburrow87

    rburrow87 Veteran Member

    Messages:
    153
    Likes Received:
    51
    Joined:
    Apr 6, 2016
    Location:
    San Diego, CA
    That's the one I'm using in my 75 with a TH350 and factory shifter. Also used their clips because mine had the wrong one at the trans side: https://www.summitracing.com/parts/siw-sos-u2 Seemed to match the one at the shifter end so the factory clips are the same.

    The little boot for the cable was smaller than the original one. I sandwiched the new one between the body and the original boot and it seems to seal up well.
     
    bazookatooths likes this.

Share This Page