Sniper FI Fuel Pressure troubleshooting

Discussion in 'High Tech Retrofits' started by 8pack, Oct 3, 2019.

  1. 8pack

    8pack Veteran Member Lifetime Gold Member

    Messages:
    2,964
    Likes Received:
    313
    Joined:
    Aug 29, 2007
    Location:
    Western, MA
    ok, thanks. Correct on the wiring!
     
  2. 71RS/SS396

    71RS/SS396 Veteran Member

    Messages:
    2,640
    Likes Received:
    43
    Joined:
    Aug 26, 2008
    Location:
    Wake Forest NC
    Make sure you aren't loosing your rpm signal, it will cause it to shut the fuel pump off. I've seen this happen intermittently and it will cycle the fuel pump on and off momentarily.
     
  3. biker

    biker Veteran Member

    Messages:
    4,172
    Likes Received:
    2,054
    Joined:
    Dec 7, 2014
    Location:
    Canada
    I have not been able to find a decent relay that will last more than a few weeks without sticking on. Such crap now. Having said that, it sure sounds more of a pumpy issue than relay/wiring. The setup Corky has in the tank does seem to be solid and something I will use as soon as I pick a FI system.
     
  4. 76z28

    76z28 Veteran Member

    Messages:
    2,392
    Likes Received:
    183
    Joined:
    Jun 29, 2009
    Location:
    bakersfield
    Really?
    I bought the water rated amazon ones(I think they were 5 dollars a piece) and haven't had issues at all.
    One runs my fuel pump, and two run my fans. They have been flawless so far.


    As for your fuel pressure issue, your pressure shouldn't go down at WOT, I would say that isn't normal or your pump can't keep up.
    I have an in tank 400lph from tanks inc that goes to a regulator that is vacuum referenced.
    At idle I have about 38 but at WOT it builds pressure and stays right at 43 the entire time.
     
  5. biker

    biker Veteran Member

    Messages:
    4,172
    Likes Received:
    2,054
    Joined:
    Dec 7, 2014
    Location:
    Canada
    Maybe just poor luck, but I've tried 3 of the typical Bosch style relays (not actual Bosch, but chineseum), and they all started sticking on in short order. Not like I was asking lots from them, I used them to bring 12v to my HEI. Turn key off, car keeps running without tach and gauges. Finally just went back to the stock 12v ignition wire, problem solved. But i agree, OP issue is pump related.
     
  6. 8pack

    8pack Veteran Member Lifetime Gold Member

    Messages:
    2,964
    Likes Received:
    313
    Joined:
    Aug 29, 2007
    Location:
    Western, MA
    My relay doesn't stick on, it seems to fail with heat and cut off.

    I just re-wired and removed the old relays and wired in Hella waterproof relays. They are much more robust than the standard relays. I also wrapped them in high heat fiberglass with an aluminum top coat used for exhaust applications which I had left over. I relocated them to the front of the fender liner down by the frame rail.

    I am not 100% sure it will solve the problem as it could still be the PS fuel pump, but I plan to go out for a few hours of local driving this weekend and see how it goes. I am told it is very rare for those pumps to fail.
     
  7. 8pack

    8pack Veteran Member Lifetime Gold Member

    Messages:
    2,964
    Likes Received:
    313
    Joined:
    Aug 29, 2007
    Location:
    Western, MA
    Can you help me understand why you think it is pump related?
     
  8. biker

    biker Veteran Member

    Messages:
    4,172
    Likes Received:
    2,054
    Joined:
    Dec 7, 2014
    Location:
    Canada
    Good job on the relay choice and install. I totally agree that you should eliminate any nagging doubts regarding relays and heat. I'm leaning towards pump only because the symptoms you describe seem to point to it. The mechanical pump upgrade seemed to help, which may help a weak main pump (or float issue?). Then when it shut down on you and the pressure wavered on startup. Maybe sucked some air as you said?

    Believe me, I will be the first one to cheer if it was just a poopy relay.

    Did you eliminate any weird intermittent tank vent issues?
     
  9. 8pack

    8pack Veteran Member Lifetime Gold Member

    Messages:
    2,964
    Likes Received:
    313
    Joined:
    Aug 29, 2007
    Location:
    Western, MA
    Thanks for sticking with me on this. The return from the power surge tank to the fuel tank is 1/4".

    What symptoms or issues will arise if the return is too restricted? Others have not had issues using the stock return and RobbMc said it should be fine. I can put a pressure gauge in line on the return and see what I am getting.
     
  10. biker

    biker Veteran Member

    Messages:
    4,172
    Likes Received:
    2,054
    Joined:
    Dec 7, 2014
    Location:
    Canada
    I think restricting the return is how some injection systems regulate system pressure. So, I would think that if your return line is too small, you would see high pressure at the throttle body.
    Having said that, I think someone suggested earlier to have a look at your regulator. Maybe something to try if the relays don't solve things. It is probably on the return side of the TB and easy to get to.
     

Share This Page