ST10 from 3rd gen

CT1275

Member
Nov 24, 2019
92
Hey guys, fairly new here. I have an opportunity to get a Power Brute ST10 but not sure if the fit is the same. This would be out of an 84 Camaro going into a 78 Camaro. Will the 78 ITM shifter mount up to that trans and will the trans install into the 78 without mods?
Thanks guys!
 

badazz81z28

Veteran Member
May 4, 2001
21,794
Alabama
Its the fact its a T-10, not what car it came out of. A T-10 is a 4 speed that will surely bolt in. The BGW 5 speed is another story.
 

CT1275

Member
Nov 24, 2019
92
Yeah in my head once he said 84 camaro I was thinking the trans was even though I saw the stamp before...lol. but I also thought they used the T10 into the 80s for V8 cars and trucks.
Anyway, if they all bolt up the same and assuming same dimensions I should be good? The tail looked a little different than the one I had so I thought it might bolt up different. But that was a 903 tail and this is 906 tail. The picture of the shifter mounting holes was very unclear. Hes supposed to be sending a new pic.
 

Randy 81

Veteran Member
Oct 28, 2009
938
Loganville, Ga
The 4-speed did stop in 1982 and the tail shaft is a bit different. I had one with a Hurst comp plus shifter, the shifter sits on top of the tail housing with an L-shaped bracket that bolts on the pass side. This made room for the torque arm mount. It still had a traditional trans mount and worked in the 71 Camaro I put it in. I did use the shifter it had, not sure if an older shifter would work, didn't have one to try out.
 

CT1275

Member
Nov 24, 2019
92
The 4-speed did stop in 1982 and the tail shaft is a bit different. I had one with a Hurst comp plus shifter, the shifter sits on top of the tail housing with an L-shaped bracket that bolts on the pass side. This made room for the torque arm mount. It still had a traditional trans mount and worked in the 71 Camaro I put it in. I did use the shifter it had, not sure if an older shifter would work, didn't have one to try out.
Did you have to do much to make it work? What all did you have to do? The shifter comes up through the console in the same position, right?
 

CT1275

Member
Nov 24, 2019
92
It isn't in the same position, it is a bit further back and sits high, here is a link to what it looks like, down in the thread a bit: https://www.thirdgen.org/forums/transmissions-drivetrain/604036-t10-shifter-mounting-plate.html
It bolted up no problem, shifter is the main difference. Also, the gear ratios are quite a wide spread compared to other T10s
How much further back? Can it use the same hole in the floor and the center console? Looks a lot taller than my 78 ST10.
 

Randy 81

Veteran Member
Oct 28, 2009
938
Loganville, Ga
I can't tell how far, it was 20+ years ago when I had it. My Camaro was an AT car, so it didn't have the shifter hump, so no point of reference.
 

badazz81z28

Veteran Member
May 4, 2001
21,794
Alabama
It isn't in the same position, it is a bit further back and sits high, here is a link to what it looks like, down in the thread a bit: https://www.thirdgen.org/forums/transmissions-drivetrain/604036-t10-shifter-mounting-plate.html
It bolted up no problem, shifter is the main difference. Also, the gear ratios are quite a wide spread compared to other T10s

The tail housing doesn't seem different. I can't say for the shifter rods or the shifter it self working, but just by looking at it...It seems all you need is the correct bracket to put that 3rd gen shifter back into the 60-70s location. You might need new rods.
 




Latest posts

Top