That little 170cc E-tech 406...

Marv D

Veteran Member
Lifetime Gold Member
...is still impressing the crap out of me. Heres a page with some pics from last weekend.
And before you think this is a gutted race car,, NO, the only thing missing is the crunched, big 'sofa' style front bumper and the back seat! Has the stock inner fender panels, stock springs and stock gas shocks all the way around, nothing but a set of CE slapper bars on a 10bolt housing with a GM posi unit, bolt in SFC's, no roll bar or cage, only interior missing is the back seat, but the front seats were replaced with Summit composit buckets. Patrick at Prosystems finished up a XC series 4150 and delivered it yesterday (Christmas came a couple of days early in Az. :) ). You might say Dana's kind-of anxiously awaiting Jan 6th for the next T&T. I don't know why!!!! :eek:
 

Marv D

Veteran Member
Lifetime Gold Member
That's whats surprising me too Martin. There is no real high tech combination to this. A Hughes street TH350, a Jeggs 2800 convertor, 4.10 gears, a Lunati streetmaster hydraulic cam (#00012) 10.2:1 ,, and Dana's launching from 1500rpm and footbraking, shifting at 6000 and going through the traps at 6300ish ([email protected]) in a 3300-3400 pound car. I tell ya, them little 9" Hoosiers are sure doing as good of a job as those little E-tech's
 

79CamaroZ28

Veteran Member
Aug 1, 2001
1,243
tucson, Arizona
Wow Marv, Thats a big change from the last time i saw that car.. Looks like hes having some fun with it now...You have all my respect for helping dana to get the car running right... I hope youguys have a great x-mas and a better new year...

P.s. The truck is down for now, For some reason the msd is draining my battery when i let it sit for more than 2 days and it has a bad pop and bang at 3,000 all the way to 5,000.. will not free rev to 3,500, tried different carb and everything and the same... timing is dead on and all valves are in order.....

Nate
 

Marv D

Veteran Member
Lifetime Gold Member
Nate, if that MSD box has a rev limiter,, bump it up as high as possible and see what happens. Dana had the same problem (only at 5800) with a brand new Mallory box. As soon as he bumped the rev limiter from 6500 to 8000 the high rpm problem weny bye bye.
 

79CamaroZ28

Veteran Member
Aug 1, 2001
1,243
tucson, Arizona
Marv, Im guessing that i fouled all the plugs, i just pulled one and its completly black and smells really bad of gas... Im thinking it was from the carb we tried on it to clear the problem up, was ubber rich and wouldnt idle.. but still even before then it would still pop and bang at 5,000 with a 6,500 chip in it... So i pulled the chip and matted it and it still did it.. Im gonna try doing plugs and wires on it before i dig any deaper (tayler race pro wires and bosch plugs) Nate
 

craggar

Veteran Member
Jul 28, 1999
5,769
edmonton
That car is working awesome Marv!He can go hunting BB's with those times;) Congrats to both of you. I do agree with Sheldon there's definitely something missing off the front.:D
 




Top